Welcome to CPGNation.com! Log in or Sign up to interact with the CPGNation community.
TCITech1
Last Activity:
Jul 1, 2013
Joined:
Jun 8, 2009
Messages:
252
Likes Received:
0
Trophy Points:
0

Share This Page

TCITech1

New Member

TCITech1 was last seen:
Jul 1, 2013
    1. Silverbullet
      Silverbullet
      Hi, I bought the ez tcu and I am using it on a 4l80e with carb. It is wired per the directions, the tps signal is reading right and all my connections are good. When just the switch is on for the transmission controller the light is solidt, when I turn the ignition on it stays the same, as soon as I start it the light becomes becomes intermittent with comm error appearing. The 12v is ran to a separate switch.
      .
    2. Nick68acadian
      Nick68acadian
      Hi. I am having problems with my new TCI 700R4 part#371100. First and second feel good but third feels like neutral. Fluid level is good, shifter linkage was triple checked and I have TCI TV corrector kit installed ( played with TV adjustment, only changes when it shifts ). Any thing I can check with it in the car would be great. Thanks
    3. Nick68acadian
      Nick68acadian
      Hi. I am having problems with my new TCI 700R4 part#371100. First and second feel good but third feels like neutral. Fluid level is good, shifter linkage was triple checked and I have TCI TV corrector kit installed ( played with TV adjustment, only changes when it shifts ). Any thing I can check with it in the car would be great. Thanks
    4. Dart Dad
      Dart Dad
      The car did move on its own power (in Drive) I am going to let some fluid out as I may have too much per Chris a TCI. I will try that and also check the level in neutral with it running compared to the level not running to make sure it falls.I will let you know how that goes. Thanks, Rob
    5. Dart Dad
      Dart Dad
      The car did move on its own power (in Drive) I am going to let some fluid out as I may have too much per Chris a TCI. I will try that and also check the level in neutral with it running compared to the level not running to make sure it falls.I will let you know how that goes. Thanks, Rob
    6. Dart Dad
      Dart Dad
      Could you look at my post or emails. I have sent 2 emails, and set up this post. Should I just call tech support? Please let me know. Thanks, Rob S
    7. Dart Dad
      Dart Dad
      Could you look at my post or emails. I have sent 2 emails, and set up this post. Should I just call tech support? Please let me know. Thanks, Rob S
    8. RonnieW
      RonnieW
      I have a question posted on the forum. thanks, Ronnie
    9. RonnieW
      RonnieW
      I have a question posted on the forum. thanks, Ronnie
  • Loading...
  • Loading...