Welcome to CPGNation.com! Log in or Sign up to interact with the CPGNation community.
TurboNova
Last Activity:
May 14, 2019
Joined:
Jan 30, 2009
Messages:
3,985
Likes Received:
23
Trophy Points:
38
Gender:
Male
Home Page:
Location:
Lake Havasu City AZ.. but mostly travel tuning
Occupation:
Owner Horsepower Connection/TheEFIStore.com

Share This Page

TurboNova

Active Member, Male, from Lake Havasu City AZ.. but mostly travel tuning

TurboNova was last seen:
May 14, 2019
    1. Phil@/355
      Phil@/355
      You were previously discussing the issue of using nitrous with the FAST EZ-EFI 1.0 system. The closed/self learning system is a problem as it would want to lean out your AFR. Do you think that using a Nitrous Express Max 4 Controller would be useful, as you can set your Nitrous/ fuel dump to met a specific AFR ? Just a thought ?
    2. mike427cars
      mike427cars
      Hello I was just wondering do you think what fast told me today could be true that I could have wiped ecu clean causing my problems just by setting up operational parameters ?
    3. Mr. Chevrolet
      Mr. Chevrolet
      Thanks TurboNova, Is it relatively easy to tune? I plan on putting a blower cam in the engine prior to supercharging it (probably a Steve Morris spec'd piece). Also, what kind of fuel system did you use?
    4. BlowAMouse
      BlowAMouse
      Since you are in Hav-A-Zoo, was wondering if you have run across a dude named Steve George?
    5. JTz442
      JTz442
      Do you know of any shops on Long Island NY that you would recommend, I have an EZ efi 2.0 there are not to many people who are familiar with this system
      thank you
    6. jens henrik vinther
      jens henrik vinther
      Hi Brian..

      Can you tell me why i can't post any threads on the FAST forum?? When i try to post a thread it just says. " "Awaiting moderation before being displayed publicly.

      Regards.
      Jens henrik.
    7. bx4525
      bx4525
      Hi TurboNova. Trying to tune a 1993 Mustang with 83 lb. injectors, 347 with a base on the FAST XFI 2.0. Timing is advancing to much. Would you be kind enough to let me know if Parameters are ok? Crank to run mode rpm - 400, Engine rev to run mode - 12,Fixed timing test mode - checked on, Fixed timing test advance - 25.00, Crank ref angle BTDC - 50.00, Inductive delay - 40
    8. Cobraguy
      Cobraguy
      Hey Brian, thanks again for taking my calls and all your help. Your websites and posting are refreshing to a newbie like me and finally the solution to end all efi unknowns.
      The AF targets you recommended are spot on. Just a few more gremlins to get rid of. How can I stop a slight stumble at 3000rpm? that makes the cruise AF 13.2 jump north of 14. while creating that stumble/hesitation effect?
    9. Msracing89
      Msracing89
      Hello there.

      I have been running EZ 1.0 for several years and no issues. Fired the car up the other day and the IAC did not want to stop running at a 180 count. I drove off and it made the car run very rich and at stops the car would shut off and not idle to due to the high IAC count. It felt like it was stuck open.......after a half hour I just let it idle and went turned the idle screw back and forth to try and get it "unstick itself" and it seemed to work as it returned to normal function.

      Should I be looking at replacing it? Or a friend said I may just be able to clean it and see if how that goes.

      Thanks-Marty
    10. Msracing89
      Msracing89
      Hello there.

      I have been running EZ 1.0 for several years and no issues. Fired the car up the other day and the IAC did not want to stop running at a 180 count. I drove off and it made the car run very rich and at stops the car would shut off and not idle to due to the high IAC count. It felt like it was stuck open.......after a half hour I just let it idle and went turned the idle screw back and forth to try and get it "unstick itself" and it seemed to work as it returned to normal function.

      Should I be looking at replacing it? Or a friend said I may just be able to clean it and see if how that goes.

      Thanks-Marty
    11. TurboNova
      TurboNova
      Joe at this time there is the FAST XFI video that FAST sells, it's kinda dry and some of the stuff is dated back to before the version 1.34 and there is the class that I teach through EFI U for FAST. The last class will be at Indy for the PRI show in Dec. After that I am not sure what next year will bring.
    12. TurboNova
      TurboNova
      Joe at this time there is the FAST XFI video that FAST sells, it's kinda dry and some of the stuff is dated back to before the version 1.34 and there is the class that I teach through EFI U for FAST. The last class will be at Indy for the PRI show in Dec. After that I am not sure what next year will bring.
    13. JB Racing
      JB Racing
      Hi Brian,
      I would like to know if their is a Shop Manual where I can better understand how to Tune Cars running Classic or XFI FAST?
      Thanks
      Joe
    14. JB Racing
      JB Racing
      Hi Brian,
      I would like to know if their is a Shop Manual where I can better understand how to Tune Cars running Classic or XFI FAST?
      Thanks
      Joe
    15. Stroked_68
      Stroked_68
      I have the a1000 now and have it mounted in between the diff. and tank and lowered to about the middle of tank. Any aftermarket tanks that I can put that pump in that will bolt up in stock tank location?
    16. Stroked_68
      Stroked_68
      I have the a1000 now and have it mounted in between the diff. and tank and lowered to about the middle of tank. Any aftermarket tanks that I can put that pump in that will bolt up in stock tank location?
    17. Stroked_68
      Stroked_68
      Hey Brian, I have recently installed the Fast multiport kit (part#3011454-10E) to my 68 Camaro BB and having problems with the pump losing prime. I am thinking a intank pump setup will fix the problem and would like to know which one you recommend going with for my car. I actually had a lot more details in my first message but it wouldn't let me post because of the length. Thanks for any help!
    18. Stroked_68
      Stroked_68
      Hey Brian, I have recently installed the Fast multiport kit (part#3011454-10E) to my 68 Camaro BB and having problems with the pump losing prime. I am thinking a intank pump setup will fix the problem and would like to know which one you recommend going with for my car. I actually had a lot more details in my first message but it wouldn't let me post because of the length. Thanks for any help!
    19. belvedere
      belvedere
      idle af 13.3
      cruse af 14.0
      wot af 12.8
      these are the pre loaded settings.the book said start it and drive.and I did.thank you for any help.
    20. belvedere
      belvedere
      idle af 13.3
      cruse af 14.0
      wot af 12.8
      these are the pre loaded settings.the book said start it and drive.and I did.thank you for any help.
  • Loading...
  • Loading...
  • About

    Gender:
    Male
    Home Page:
    http://www.TheEFIStore.com
    Location:
    Lake Havasu City AZ.. but mostly travel tuning
    Occupation:
    Owner Horsepower Connection/TheEFIStore.com
    EFI tuner, Dyno Testing, Wiring

    Drag Racing and Offshore Boats

    Interact

    Content:
    Skype:
    brian.macy1
    Facebook:
    turbonova
    Twitter:
    EFITeacher

    Signature

    Brian Macy
    Owner Horsepower Connection
    and
    TheEFIStore.com

    e-mail brian@horsepowerconnection.com

    Horsepower Connection.com
    TheEFIStore.com
    Dealer for FAST, Comp Cams, ZEX, RHS, TCI and more.
    e-mail or call for prices on any of the Comp line of products
    shop 928-706-6112
    cell 360-280-6112