Welcome to CPGNation.com! Log in or Sign up to interact with the CPGNation community.

incompatible device message

Discussion in 'FAST Support Forum' started by bill c, Mar 24, 2018.

  1. bill c

    bill c New Member

    Joined:
    Apr 23, 2017
    a friend of mine just got his xfi 2.0 box back from being upgraded for 16 injectors and I cannot connect to it. I have tried a computer with version 2.01 and a computer with 2.05. is there something I am doing wrong? when I hit connect it just says incompatible device. the operation manual just says you may need to update the software or firmware. is there something newer than 2.05? if I put my xfi 2.0 box in it communicates fine
     
  2. Fastmanefi

    Fastmanefi Active Member

    Joined:
    Jun 4, 2011
    Location:
    Sonora, CA
    2.05 requires the B9 Flash firmware.
     
  3. bill c

    bill c New Member

    Joined:
    Apr 23, 2017
    I just found out that when he sent in the unit it was also upgraded from the older c/com to the 2.0 and on the box it says firmware xfi2.g87. my box says firmware xfi2.9d and I can connect to mine. does his box have to be flashed with one of the xfi programs or was that done when the box was updated? the box was just sent back without any information I assumed it was flashed with the latest software when it was getting updated
     

Share This Page