Welcome to CPGNation.com! Log in or Sign up to interact with the CPGNation community.

stack tuning

Discussion in 'Inglese Support Forum' started by USA69Z, Sep 14, 2012.

  1. USA69Z

    USA69Z New Member

    Joined:
    Mar 25, 2011
    Mick , ive been running a 8 stack system for about a year now and it runs resonably well..It is hooked up using the ezi efi setup ..sbc 52mm throttlebodys, 65lb inj , msd 6al , 6 speed.. what my problem is i cant get it to lean out before i get the popping ..My plugs are always wet when pulled and it is running rich all the time.blows black smoke under heavy acc . I do know that these systems need a lot of fuel as theres a ton of air flowing into it..but how can i lean it out without the 'pop'? plugs are ngk bp6ey. any ideas?

    Gav
    downunder
     
  2. amick

    amick Active Member

    Joined:
    Jul 21, 2009
    Location:
    Memphis
    Gav have you balanced all 8 stacks?
     
  3. USA69Z

    USA69Z New Member

    Joined:
    Mar 25, 2011
    Mick , yes i have a balancer and they all come in at 10-11 on the vacuum guage...im starting to think i should really have the xfi setup.. but if you guys at inglese run these systems with the ezi setup maybe there are some things i could try?
     
  4. maxwell

    maxwell Moderator Staff Member

    Joined:
    Jul 5, 2012
    Hi, USA69Z

    How much ignition timing are you running? At idle and total, please.

    Thanks
     
  5. USA69Z

    USA69Z New Member

    Joined:
    Mar 25, 2011
    Matt /Aaron , is the settings in the fast ecu different for the 'other' setting to the 'inglese' setting in the ecu? Im thinking of selecting this on a new tune..can i get hold of the 'inglese' setup guide ,, i have an ezi efi with a crossram 8 stack system here in australia.. or do you send out the same instructions for all the systems (single throttle body kit)

    Gav -Downunder
     
  6. maxwell

    maxwell Moderator Staff Member

    Joined:
    Jul 5, 2012
    The Inglese option just locks you into injector sizes that are available in the Inglese injection kits.
    I would choose Other for your setup.
    The single throttle body instructions tell you how to use the handheld and basic guidelines. An 8 stack or multi-port setup works the same way, except it looks different.
    All EFI systems are very similar.
     
  7. USA69Z

    USA69Z New Member

    Joined:
    Mar 25, 2011
    thanx Matt , just a thought as im getting more and more frustrated with this setup which cost me over 10g to set up..its never been perfect yet.. and now seems to be going backwards ... now i get erratic popping as a lean symptom from my throttlebodys,, theres flame in there when it pops.. Ive richened it up at idle and no change..
     
  8. maxwell

    maxwell Moderator Staff Member

    Joined:
    Jul 5, 2012
    Well, the intake valve should be closed during combustion. Sounds like timing or a mechanical problem if you are getting flames up through the intake.
     
  9. USA69Z

    USA69Z New Member

    Joined:
    Mar 25, 2011
    yep , im starting to think the timing now.. its movimg to other cylinders now...i will re do the dissy install and re time... thanx for all the help
     
  10. maxwell

    maxwell Moderator Staff Member

    Joined:
    Jul 5, 2012
    Let me know what you find.
     

Share This Page